]> asedeno.scripts.mit.edu Git - 1ts-debian.git/commitdiff
Accept sourceforge patch to build without kerberos support
authorhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Fri, 12 Jul 2002 01:15:31 +0000 (01:15 +0000)
committerhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Fri, 12 Jul 2002 01:15:31 +0000 (01:15 +0000)
git-svn-id: svn://svn.1ts.org/debian/trunk/zephyr@140 cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f

clients/zctl/zutils.c
debian/control
debian/patch.no_kerberos_support [new file with mode: 0644]
zwgc/zutils.c

index 26d4902a119cca24a0d0b9476ea035abf009c10a..87d54b84aa4174f077b1a798e5742598f5cc5b12 100644 (file)
@@ -9,12 +9,15 @@
 #include <sys/param.h>
 
 #include <zephyr/zephyr.h>
+#ifdef HAVE_KRB4
 #include <krb_err.h>
+#endif
 
 #include "zutils.h"
 
 #ifdef ZWGC
 #include "subscriptions.h"
+#define ZGetWGPort() (ZGetPort())
 #endif
 
 #ifdef ZCTL
@@ -183,7 +186,11 @@ Code_t set_exposure(zgalaxy, exposure)
            }
 #endif
        }
-       return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
+#ifdef HAVE_KRB4
+       if (retval == KRBET_AD_NOTGT)
+           retval = ZERR_NONE;
+#endif
+       return(retval);
     } else {
        if ((retval = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE)
            return(retval);
@@ -471,17 +478,23 @@ Code_t load_all_sub_files(type, basefile)
            printf("For galaxy %s:\n", galaxy);
 
        if ((i == 0) && basefile) {
-           if ((code = load_sub_file(type, basefile, galaxy))
-               != ZERR_NONE)
+           code = load_sub_file(type, basefile, galaxy);
+           if ((code != ZERR_NONE) &&
+               (code != ENOENT))
                retval = code;
        }
 
-       if ((code = load_sub_file(type, basefile?fn:NULL, galaxy))
-           != ZERR_NONE)
+       code = load_sub_file(type, basefile?fn:NULL, galaxy);
+       if ((code != ZERR_NONE) &&
+           (code != ENOENT))
            retval = code;
 
        if (type == LIST)
                printf("\n");
     }
-    return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
+#ifdef HAVE_KRB4
+    if (retval == KRBET_AD_NOTGT)
+       retval = ZERR_NONE;
+#endif
+    return(retval);
 }
index 7ce124d15326533b0dd3f56b9eff2c1881956e77..3c0a4a6ca114c911defbf5a37c6848ec5e4ffce8 100644 (file)
@@ -5,7 +5,8 @@ Maintainer: Karl Ramm <kcr@debian.org>
 Build-Depends: debhelper, libares-dev, libkrb5-dev (>= 1.2.2-4), comerr-dev, ss-dev, libreadline4-dev, xlibs-dev | xlib6g-dev, libxaw-dev | xlib6g-dev, libncurses5-dev, bison, libzephyr-dev, libhesiod-dev
 Standards-Version: 3.1.1
 
-Package: libzephyr4itecture: any
+Package: libzephyr4
+architecture: any
 Depends: ${shlibs:Depends}
 Conflicts: libzephyr4-krb
 Description: The original "Instant Message" system libraries without Kerberos
@@ -16,7 +17,8 @@ Description: The original "Instant Message" system libraries without Kerberos
  users.  Users can view incoming Zephyr messages as windowgrams
  (transient X windows) or as text on a terminal.
 
-Package: libzephyr4itecture: any
+Package: libzephyr4-krb
+architecture: any
 Depends: ${shlibs:Depends}, krb4-config
 Conflicts: libzephyr4
 Provides: libzephyr4
diff --git a/debian/patch.no_kerberos_support b/debian/patch.no_kerberos_support
new file mode 100644 (file)
index 0000000..d6e128a
--- /dev/null
@@ -0,0 +1,152 @@
+
+Index: clients/zctl/zutils.c
+===================================================================
+RCS file: /cvsroot/zephyr/zephyr/clients/zctl/zutils.c,v
+retrieving revision 1.2
+retrieving revision 1.4
+diff -u -r1.2 -r1.4
+--- clients/zctl/zutils.c      11 Jul 2002 04:24:15 -0000      1.2
++++ clients/zctl/zutils.c      12 Jul 2002 00:58:13 -0000      1.4
+@@ -9,12 +9,15 @@
+ #include <sys/param.h>
+ #include <zephyr/zephyr.h>
++#ifdef HAVE_KRB4
+ #include <krb_err.h>
++#endif
+ #include "zutils.h"
+ #ifdef ZWGC
+ #include "subscriptions.h"
++#define ZGetWGPort() (ZGetPort())
+ #endif
+ #ifdef ZCTL
+@@ -183,7 +186,11 @@
+           }
+ #endif
+       }
+-      return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
++#ifdef HAVE_KRB4
++      if (retval == KRBET_AD_NOTGT)
++          retval = ZERR_NONE;
++#endif
++      return(retval);
+     } else {
+       if ((retval = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE)
+           return(retval);
+@@ -471,17 +478,23 @@
+           printf("For galaxy %s:\n", galaxy);
+       if ((i == 0) && basefile) {
+-          if ((code = load_sub_file(type, basefile, galaxy))
+-              != ZERR_NONE)
++          code = load_sub_file(type, basefile, galaxy);
++          if ((code != ZERR_NONE) &&
++              (code != ENOENT))
+               retval = code;
+       }
+-      if ((code = load_sub_file(type, basefile?fn:NULL, galaxy))
+-          != ZERR_NONE)
++      code = load_sub_file(type, basefile?fn:NULL, galaxy);
++      if ((code != ZERR_NONE) &&
++          (code != ENOENT))
+           retval = code;
+       if (type == LIST)
+               printf("\n");
+     }
+-    return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
++#ifdef HAVE_KRB4
++    if (retval == KRBET_AD_NOTGT)
++      retval = ZERR_NONE;
++#endif
++    return(retval);
+ }
+Index: zwgc/zutils.c
+===================================================================
+RCS file: /cvsroot/zephyr/zephyr/zwgc/zutils.c,v
+retrieving revision 1.2
+retrieving revision 1.3
+diff -u -r1.2 -r1.3
+--- zwgc/zutils.c      11 Jul 2002 04:24:16 -0000      1.2
++++ zwgc/zutils.c      12 Jul 2002 00:59:58 -0000      1.3
+@@ -9,7 +9,9 @@
+ #include <sys/param.h>
+ #include <zephyr/zephyr.h>
++#ifdef HAVE_KRB4
+ #include <krb_err.h>
++#endif
+ #include "zutils.h"
+@@ -122,8 +124,8 @@
+     }
+ }
+-Code_t set_exposure(galaxy, exposure)
+-     char *galaxy;
++Code_t set_exposure(zgalaxy, exposure)
++     char *zgalaxy;
+      char *exposure;
+ {
+     char *exp_level, *galaxy_exp_level, zvar[1024];
+@@ -132,15 +134,15 @@
+     exp_level = ZParseExposureLevel(exposure);
+-    if (galaxy && strcmp(galaxy, "*") == 0) {
++    if (zgalaxy && strcmp(zgalaxy, "*") == 0) {
+       if (retval = ZGetGalaxyCount(&cnt))
+               return(retval);
+       for (i=0; i<cnt; i++) {
+-          if (retval = ZGetGalaxyName(i, &galaxy))
++          if (retval = ZGetGalaxyName(i, &zgalaxy))
+               return(retval);
+-          sprintf(zvar, "exposure-%s", galaxy);
++          sprintf(zvar, "exposure-%s", zgalaxy);
+                               
+           if (galaxy_exp_level = ZGetVariable(zvar)) {
+               if (strcmp(galaxy_exp_level, EXPOSE_NETVIS) == 0)
+@@ -166,7 +168,7 @@
+           if (strcmp(galaxy_exp_level, EXPOSE_NONE) == 0)
+               continue;
+-          if ((code = ZSetLocation(galaxy, exp_level)) != ZERR_NONE) {
++          if ((code = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE) {
+              retval = code;
+              continue;
+           }
+@@ -184,9 +186,13 @@
+           }
+ #endif
+       }
+-      return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
++#ifdef HAVE_KRB4
++      if (retval == KRBET_AD_NOTGT)
++          retval = ZERR_NONE;
++#endif
++      return(retval);
+     } else {
+-      if ((retval = ZSetLocation(galaxy, exp_level)) != ZERR_NONE)
++      if ((retval = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE)
+           return(retval);
+ #ifdef ZCTL
+       if (strcmp(exp_level,EXPOSE_NONE) == 0) {
+@@ -486,5 +492,9 @@
+       if (type == LIST)
+               printf("\n");
+     }
+-    return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
++#ifdef HAVE_KRB4
++    if (retval == KRBET_AD_NOTGT)
++      retval = ZERR_NONE;
++#endif
++    return(retval);
+ }
+
index 91d2523fb9d5400013d0e5d6dd3cc2411465b3e4..87d54b84aa4174f077b1a798e5742598f5cc5b12 100644 (file)
@@ -9,7 +9,9 @@
 #include <sys/param.h>
 
 #include <zephyr/zephyr.h>
+#ifdef HAVE_KRB4
 #include <krb_err.h>
+#endif
 
 #include "zutils.h"
 
@@ -122,8 +124,8 @@ void fix_macros2(src,dest)
     }
 }
 
-Code_t set_exposure(galaxy, exposure)
-     char *galaxy;
+Code_t set_exposure(zgalaxy, exposure)
+     char *zgalaxy;
      char *exposure;
 {
     char *exp_level, *galaxy_exp_level, zvar[1024];
@@ -132,15 +134,15 @@ Code_t set_exposure(galaxy, exposure)
 
     exp_level = ZParseExposureLevel(exposure);
 
-    if (galaxy && strcmp(galaxy, "*") == 0) {
+    if (zgalaxy && strcmp(zgalaxy, "*") == 0) {
        if (retval = ZGetGalaxyCount(&cnt))
                return(retval);
 
        for (i=0; i<cnt; i++) {
-           if (retval = ZGetGalaxyName(i, &galaxy))
+           if (retval = ZGetGalaxyName(i, &zgalaxy))
                return(retval);
 
-           sprintf(zvar, "exposure-%s", galaxy);
+           sprintf(zvar, "exposure-%s", zgalaxy);
                                
            if (galaxy_exp_level = ZGetVariable(zvar)) {
                if (strcmp(galaxy_exp_level, EXPOSE_NETVIS) == 0)
@@ -166,7 +168,7 @@ Code_t set_exposure(galaxy, exposure)
            if (strcmp(galaxy_exp_level, EXPOSE_NONE) == 0)
                continue;
 
-           if ((code = ZSetLocation(galaxy, exp_level)) != ZERR_NONE) {
+           if ((code = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE) {
               retval = code;
               continue;
            }
@@ -184,9 +186,13 @@ Code_t set_exposure(galaxy, exposure)
            }
 #endif
        }
-       return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
+#ifdef HAVE_KRB4
+       if (retval == KRBET_AD_NOTGT)
+           retval = ZERR_NONE;
+#endif
+       return(retval);
     } else {
-       if ((retval = ZSetLocation(galaxy, exp_level)) != ZERR_NONE)
+       if ((retval = ZSetLocation(zgalaxy, exp_level)) != ZERR_NONE)
            return(retval);
 #ifdef ZCTL
        if (strcmp(exp_level,EXPOSE_NONE) == 0) {
@@ -486,5 +492,9 @@ Code_t load_all_sub_files(type, basefile)
        if (type == LIST)
                printf("\n");
     }
-    return((retval == KRBET_AD_NOTGT)?ZERR_NONE:retval);
+#ifdef HAVE_KRB4
+    if (retval == KRBET_AD_NOTGT)
+       retval = ZERR_NONE;
+#endif
+    return(retval);
 }