]> asedeno.scripts.mit.edu Git - 1ts-debian.git/commitdiff
* Finalize version
authorhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Wed, 28 Mar 2001 23:13:42 +0000 (23:13 +0000)
committerhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Wed, 28 Mar 2001 23:13:42 +0000 (23:13 +0000)
* Build Kerberized and non-kerbberized versions

git-svn-id: svn://svn.1ts.org/debian/trunk/zephyr@24 cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f

debian/changelog
debian/control
debian/rules

index 99c59482446a7a0a71ce3961e23035d3e90be968..7dbd5382c3610ecb182038916b1c8b28681e7412 100644 (file)
@@ -5,8 +5,9 @@ zephyr (2.1.20000421.SNAPSHOT-8) unstable; urgency=low
   * Produce libzephyr3 package and used shared libs
   * Clean up debian/rules to only call movefiles once
   * Depend on libxaw-dev for sid/woody
+  * Support both Kerberos and non-Kerberos
 
- --
+ -- Sam Hartman <hartmans@mit.edu>  Wed, 28 Mar 2001 17:57:21 -0500
 
 zephyr (2.1.20000421.SNAPSHOT-7) unstable; urgency=low
 
index afadea7f5dd276196278ae1193168c430709529b..290eb561b7ca85b2f782ea0b72bcbdec25fdb0d6 100644 (file)
@@ -8,7 +8,18 @@ Standards-Version: 3.1.1
 Package: libzephyr3
 Architecture: any
 Depends: ${shlibs:Depends}
-Description: The original "Instant Message" system libraries
+Description: The original "Instant Message" system libraries without Kerberos
+ This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
+ Zephyr allows users to send messages to other users or to groups of
+ users.  Users can view incoming Zephyr messages as windowgrams
+ (transient X windows) or as text on a terminal.
+
+Package: libzephyr3-krb
+Architecture: any
+Depends: ${shlibs:Depends}
+Conflicts: libzephyr3
+Provides: libzephyr3
+Description: The original "Instant Message" system libraries with Kerberos 
  This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
  Zephyr allows users to send messages to other users or to groups of
  users.  Users can view incoming Zephyr messages as windowgrams
@@ -29,7 +40,17 @@ Description: The original "Instant Message" system client
 Package: zephyr-server
 Architecture: any
 Depends: ${shlibs:Depends}
-Description: The original "Instant Message" system-server
+Description: The original "Instant Message" system-server without Kerberos
+ This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
+ Zephyr allows users to send messages to other users or to groups of
+ users.  Users can view incoming Zephyr messages as windowgrams
+ (transient X windows) or as text on a terminal.
+
+Package: zephyr-server-krb
+Architecture: any
+Depends: ${shlibs:Depends}, libzephyr3-krb
+Conflicts: zephyr-server
+Description: The original "Instant Message" system-server with Kerberos
  This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
  Zephyr allows users to send messages to other users or to groups of
  users.  Users can view incoming Zephyr messages as windowgrams
index 2d2fa530b58ee7e5127069d893439134b95ea7e4..708cee1ea900d4426e88cf8379c4c678c616b4a6 100755 (executable)
 #export DH_VERBOSE=1
 
 # This is the debhelper compatability version to use.
-export DH_COMPAT=2
+export DH_COMPAT=3
 
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 SONAME=3
+CONFIGURE_ROOT=--prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc --datadir=/etc  --with-ares=/usr
+
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc --datadir=/etc --with-krb4=/usr --with-ares=/usr
-
+       -mkdir krb
+       cd krb&&../configure --with-krb4=/usr $(CONFIGURE_ROOT)
+       -mkdir no-krb
+       cd no-krb&&../configure $(CONFIGURE_ROOT)
        touch configure-stamp
 
 build: configure-stamp build-stamp
@@ -28,32 +33,30 @@ build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
-       -rm -f lib/zephyr/*.o
-       $(MAKE) -C lib                  \
-        FPIC=                                  \
-        LIBEXT=a
-       rm -f lib/zephyr/*.o
-       $(MAKE) LIBEXT=so \
-               FPIC=-fpic SONAME=$(SONAME)
+       set -e; \
+       for dir in krb no-krb ; do  \
+               cd $$dir; \
+       rm -f lib/zephyr/*.o || true; \
+               $(MAKE) -C lib                  \
+                FPIC=                                  \
+                LIBEXT=a; \
+               rm -f lib/zephyr/*.o; \
+               $(MAKE) LIBEXT=so \
+                       FPIC=-fpic SONAME=$(SONAME); \
+               cd ..; \
+               done
 
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       -rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f config.cache config.log config.status h/config.h \
-       Makefile clients/Makefile clients/xzwrite/Makefile \
-       clients/zaway/Makefile clients/zctl/Makefile \
-       clients/zleave/Makefile clients/zlocate/Makefile \
-       clients/zmailnotify/Makefile clients/znol/Makefile \
-       clients/zpopnotify/Makefile clients/zshutdown_notify/Makefile \
-       clients/zstat/Makefile clients/zwrite/Makefile lib/Makefile \
-       libdyn/Makefile server/Makefile zhm/Makefile zwgc/Makefile \
-       server/version.h
+       -rm -rf krb no-krb debian/tmp-krb
+       -rm debian/zephyr-server-krb.*
+       -rm debian/libzephyr3-krb.files
 
        dh_clean
 
@@ -62,15 +65,20 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
+       -rm -rf debian/tmp-krb
        dh_installdirs
 
        # Add here commands to install the package into debian/tmp.
-       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       cd no-krb&&$(MAKE) install DESTDIR=`pwd`/../debian/tmp
+       cd krb&&$(MAKE)  DESTDIR=`pwd`/../debian/tmp-krb install
        mv debian/tmp/usr/lib/libzephyr.so debian/tmp/usr/lib/libzephyr.so.$(SONAME)
        ln -s libzephyr.so.$(SONAME) debian/tmp/usr/lib/libzephyr.so
+               mv debian/tmp-krb/usr/lib/libzephyr.so debian/tmp-krb/usr/lib/libzephyr.so.$(SONAME)
+       ln -s libzephyr.so.$(SONAME) debian/tmp-krb/usr/lib/libzephyr.so
        mkdir -p debian/tmp/etc/zephyr/acl
        set -x; for i in debian/acl/*; do install -c -m 544 -o root $$i debian/tmp/etc/zephyr/acl; done; set +x
        install -c -m 544 debian/zephyr.vars debian/tmp/etc/zephyr
+       cp -pr debian/tmp/etc/zephyr/acl debian/tmp-krb/etc/zephyr
 
 # Build architecture-independent files here.
 # Pass -i to all debhelper commands in this target to reduce clutter.
@@ -81,7 +89,13 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_movefiles 
+       set -e; \
+       for file  in  files init templates config postinst; do \
+               cp debian/zephyr-server.$$file debian/zephyr-server-krb.$$file; \
+               done
+       cp debian/libzephyr3.files debian/libzephyr3-krb.files
+       dh_movefiles  -plibzephyr3 -pzephyr-clients -pzephyr-server -pzephyr-de
+       dh_movefiles --sourcedir=debian/tmp-krb -plibzephyr3-krb -pzephyr-server-krb
        dh_installdebconf 
        dh_installdocs
 #      dh_installexamples
@@ -99,11 +113,10 @@ binary-arch: build install
        dh_compress
        dh_fixperms
        # You may want to make some executables suid here.
-       dh_suidregister
+       dh_makeshlibs
+       dh_shlibdeps
        dh_installdeb
-#      dh_makeshlibs
 #      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb