]> asedeno.scripts.mit.edu Git - 1ts-debian.git/commitdiff
zephyr (2.1.20000421.SNAPSHOT-8) unstable; urgency=low
authorhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Mon, 26 Mar 2001 07:15:43 +0000 (07:15 +0000)
committerhartmans <hartmans@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Mon, 26 Mar 2001 07:15:43 +0000 (07:15 +0000)
  *
  * zephyr-client -> zephyr-clients
  * Produce libzephyr3 package and used shared libs
  * Clean up debian/rules to only call movefiles once
  * Depend on libxaw-dev for sid/woody

 -- Sam Hartman <hartmans@debian.org>

git-svn-id: svn://svn.1ts.org/debian/trunk/zephyr@22 cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f

12 files changed:
debian/changelog
debian/control
debian/libzephyr-dev.files
debian/libzephyr3.files [new file with mode: 0644]
debian/rules
debian/zephyr-clients.config [moved from debian/zephyr-client.config with 53% similarity]
debian/zephyr-clients.files [moved from debian/zephyr-client.files with 100% similarity]
debian/zephyr-clients.init [moved from debian/zephyr-client.init with 95% similarity]
debian/zephyr-clients.postinst [moved from debian/zephyr-client.postinst with 83% similarity]
debian/zephyr-clients.prerm [moved from debian/zephyr-client.prerm with 95% similarity]
debian/zephyr-clients.templates [moved from debian/zephyr-client.templates with 85% similarity]
lib/Makefile.in

index 5296167fd4b7645e3aeccde7176bf7bbe8a71bd5..99c59482446a7a0a71ce3961e23035d3e90be968 100644 (file)
@@ -1,3 +1,13 @@
+zephyr (2.1.20000421.SNAPSHOT-8) unstable; urgency=low
+
+  * 
+  * zephyr-client -> zephyr-clients
+  * Produce libzephyr3 package and used shared libs
+  * Clean up debian/rules to only call movefiles once
+  * Depend on libxaw-dev for sid/woody
+
+ --
+
 zephyr (2.1.20000421.SNAPSHOT-7) unstable; urgency=low
 
   * Fix incorrect potato build-depends (xlib6g-dev instead of xlib6g)
index adcd714c2f45315e7a13969695a54b59bea1ed0c..afadea7f5dd276196278ae1193168c430709529b 100644 (file)
@@ -2,10 +2,22 @@ Source: zephyr
 Section: unknown
 Priority: optional
 Maintainer: Karl Ramm <kcr@1ts.org>
-Build-Depends: debhelper, libares-dev, libkrb5-dev, comerr-dev, ss-dev, libreadline4-dev, xlibs-dev | xlib6g-dev, libncurses5-dev, bison
+Build-Depends: debhelper, libares-dev, libkrb5-dev, comerr-dev, ss-dev, libreadline4-dev, xlibs-dev | xlib6g-dev, libxaw-dev|xlib6g-dev, libncurses5-dev, bison
 Standards-Version: 3.1.1
 
-Package: zephyr-client
+Package: libzephyr3
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: The original "Instant Message" system libraries
+ This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
+ Zephyr allows users to send messages to other users or to groups of
+ users.  Users can view incoming Zephyr messages as windowgrams
+ (transient X windows) or as text on a terminal.
+
+Package: zephyr-clients
+Provides: zephyr-client
+Replaces: zephyr-client
+Conflicts: zephyr-client
 Architecture: any
 Depends: ${shlibs:Depends}, debianutils (>= 1.6)
 Description: The original "Instant Message" system client
index bdd85564a833fc580eadbbb6766f08f0f4235b7b..539326dd047dead4b8b7257352a38b938a1bd9b4 100644 (file)
@@ -1,4 +1,5 @@
 usr/lib/libzephyr.a
+usr/lib/libzephyr.so
 usr/include/zephyr/mit-copyright.h
 usr/include/zephyr/zephyr.h
 usr/include/zephyr/zephyr_err.h
diff --git a/debian/libzephyr3.files b/debian/libzephyr3.files
new file mode 100644 (file)
index 0000000..a837249
--- /dev/null
@@ -0,0 +1 @@
+usr/lib/libzephyr.so.*
index 2463bea953f8062905ff5c1c4e6a984935912e70..2d2fa530b58ee7e5127069d893439134b95ea7e4 100755 (executable)
@@ -14,7 +14,7 @@ export DH_COMPAT=2
 
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
-
+SONAME=3
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -28,7 +28,13 @@ build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       -rm -f lib/zephyr/*.o
+       $(MAKE) -C lib                  \
+        FPIC=                                  \
+        LIBEXT=a
+       rm -f lib/zephyr/*.o
+       $(MAKE) LIBEXT=so \
+               FPIC=-fpic SONAME=$(SONAME)
 
        touch build-stamp
 
@@ -60,6 +66,8 @@ install: build
 
        # Add here commands to install the package into debian/tmp.
        $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       mv debian/tmp/usr/lib/libzephyr.so debian/tmp/usr/lib/libzephyr.so.$(SONAME)
+       ln -s libzephyr.so.$(SONAME) debian/tmp/usr/lib/libzephyr.so
        mkdir -p debian/tmp/etc/zephyr/acl
        set -x; for i in debian/acl/*; do install -c -m 544 -o root $$i debian/tmp/etc/zephyr/acl; done; set +x
        install -c -m 544 debian/zephyr.vars debian/tmp/etc/zephyr
@@ -73,11 +81,8 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_movefiles -pzephyr-client
-       dh_movefiles -pzephyr-server
-       dh_movefiles -plibzephyr-dev
-       dh_installdebconf -pzephyr-client
-       dh_installdebconf -pzephyr-server
+       dh_movefiles 
+       dh_installdebconf 
        dh_installdocs
 #      dh_installexamples
 #      dh_installmenu
@@ -104,4 +109,7 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
+
 .PHONY: build clean binary-indep binary-arch binary install configure
+
+
similarity index 53%
rename from debian/zephyr-client.config
rename to debian/zephyr-clients.config
index f04ef7ae47c5c538489b770285f8b49b5b803f33..26de8d36fd59cc3e2fe4f7c55310863fb0d5744d 100644 (file)
@@ -2,5 +2,6 @@
 
 . /usr/share/debconf/confmodule
 
-db_input high zephyr-client/servers || true
+db_input high zephyr-clients/servers || true
 db_go
+
similarity index 95%
rename from debian/zephyr-client.init
rename to debian/zephyr-clients.init
index 61a4fb26a4659a495a9f97141d06bfe807f94bf2..293d7be66ce8837510ee6bf318ea2b9c4d3bc1f7 100644 (file)
@@ -20,9 +20,9 @@ test -f $DAEMON || exit 0
 
 set -e
 
-if test -f /etc/default/zephyr-client
+if test -f /etc/default/zephyr-clients
 then
-       . /etc/default/zephyr-client
+       . /etc/default/zephyr-clients
 fi
 
 case "$1" in
similarity index 83%
rename from debian/zephyr-client.postinst
rename to debian/zephyr-clients.postinst
index c49709da3297f54c27f4486344c70794301d6717..d2104e3f9e9e6f734056dfd02b841737d80ff291 100644 (file)
@@ -31,19 +31,19 @@ case "$1" in
 
        if test -f /etc/zephyr/zephyr.conf
        then
-               if test ! -f /dev/default/zephyr-client
+               if test ! -f /dev/default/zephyr-clients
                then
-                       mv /etc/zephyr/zephyr.conf /etc/default/zephyr-client
+                       mv /etc/zephyr/zephyr.conf /etc/default/zephyr-clients
                fi
        fi
 
-       db_get zephyr-client/servers
-       if test -f /etc/default/zephyr-client
+       db_get zephyr-clients/servers
+       if test -f /etc/default/zephyr-clients
        then
-               grep -v ^zhm_args /etc/default/zephyr-client > $tmpfile || true
+               grep -v ^zhm_args /etc/default/zephyr-clients > $tmpfile || true
        fi
        echo zhm_args=\"${RET}\" >> $tmpfile
-       cat $tmpfile > /etc/default/zephyr-client
+       cat $tmpfile > /etc/default/zephyr-clients
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)
similarity index 95%
rename from debian/zephyr-client.prerm
rename to debian/zephyr-clients.prerm
index c1e3a939520ec808c95dfe7ed51100df2e1b0039..5f92d7d89a8caf14c6f13375dadc32d6e4142d0c 100644 (file)
@@ -17,7 +17,7 @@ set -e
 
 case "$1" in
     deconfigure|remove)
-       rm /etc/default/zephyr-client || true
+       rm /etc/default/zephyr-clients || true
        ;;
     upgrade)
 #    remove|upgrade|deconfigure)
similarity index 85%
rename from debian/zephyr-client.templates
rename to debian/zephyr-clients.templates
index 70a93e2c8e3ba6590f8888ef2f840acb9d49554e..eca31194da9e13c55de0e702d0c8e37410f75555 100644 (file)
@@ -1,4 +1,4 @@
-Template: zephyr-client/servers
+Template: zephyr-clients/servers
 Type: string
 Description: What are your zephyr servers?
  Please type the full names of your zephyr servers, seperated by spaces.
index 336bd6a0c026bfe639565ad264fe26aaa5bb4260..19a5e63eb37733f8b9c99ac88be748336b7692e2 100644 (file)
@@ -18,9 +18,10 @@ VPATH=@srcdir@
 CC=@CC@
 INSTALL=@INSTALL@
 RANLIB=@RANLIB@
-
+FPIC=
+DEBUG=-O
 CPPFLAGS=@CPPFLAGS@
-CFLAGS=@CFLAGS@
+CFLAGS=@CFLAGS@ ${DEBUG} ${FPIC}
 ALL_CFLAGS=${CFLAGS} -DSYSCONFDIR=\"${sysconfdir}\" -I${top_srcdir}/h \
        -I${BUILDTOP}/h ${CPPFLAGS}
 
@@ -34,12 +35,16 @@ OBJS =      zephyr_err.o ZAsyncLocate.o ZCkAuth.o ZCkIfNot.o ZClosePort.o \
        ZSendPkt.o ZSendRaw.o ZSendRLst.o ZSetDest.o ZSetFD.o ZSetSrv.o \
        ZSubs.o ZVariables.o ZWait4Not.o Zinternal.o
 
-all: libzephyr.a
+LIBEXT=a
+all: libzephyr.$(LIBEXT)
 
 libzephyr.a: ${OBJS}
        ar cru $@ ${OBJS}
        ${RANLIB} $@
 
+libzephyr.so: $(OBJS)
+       ld -shared -soname libzephyr.so.$(SONAME) -o libzephyr.so $(OBJS) -lkrb4 -ldes425 -lkrb5 -lk5crypto -lc -lcom_err  
+
 zephyr_err.c ${BUILDTOP}/h/zephyr/zephyr_err.h: zephyr_err.et
        compile_et ${srcdir}/zephyr_err.et
        mv zephyr_err.h ${BUILDTOP}/h/zephyr
@@ -49,8 +54,10 @@ zephyr_err.c ${BUILDTOP}/h/zephyr/zephyr_err.h: zephyr_err.et
 
 check:
 
-install: libzephyr.a
-       ${INSTALL} -m 644 libzephyr.a ${DESTDIR}${libdir}
+install: libzephyr.$(LIBEXT)
+       -${INSTALL} -m 644 libzephyr.a ${DESTDIR}${libdir}
+       -$(INSTALL) -m 644 libzephyr.so ${DESTDIR}$(libdir)
+
        ${INSTALL} -m 644 ${srcdir}/zephyr.1 ${DESTDIR}${mandir}/man1
 
 clean: