]> asedeno.scripts.mit.edu Git - 1ts-debian.git/commitdiff
server/kopt.c: in decomp_ticket make sure certain 32 bit values are32 bit
authorkcr <kcr@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Fri, 20 Apr 2001 21:20:29 +0000 (21:20 +0000)
committerkcr <kcr@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Fri, 20 Apr 2001 21:20:29 +0000 (21:20 +0000)
on architectures where 'int' is not 32 bits.
debian/changlelog: note this

git-svn-id: svn://svn.1ts.org/debian/trunk/zephyr@47 cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f

debian/changelog
server/kopt.c

index 44215a2d6e07e0f22c0b41f88807884e4c49fdbe..b88506266598c8b9ce6f81775eea3b1eedf2d1cd 100644 (file)
@@ -1,3 +1,10 @@
+zephyr (2.1.20000421.SNAPSHOT-11) unstable; urgency=low
+
+  * tweak to kopt.c to maybe allow alpha build to work. closes: 94600
+  * 
+
+ --
+
 zephyr (2.1.20000421.SNAPSHOT-10) unstable; urgency=low
 
   * [hartmans] libzephyr3 should not depend on krb5, closes: #93187
index eccdc21ba7f071ee22b6ef0ae5e799331ab10eae..9b777f5871e3afb548aa1325b69ede99cb7267a9 100644 (file)
@@ -541,11 +541,11 @@ decomp_ticket(tkt, flags, pname, pinstance, prealm, paddress, session,
     char *pname;                /* Authentication name */
     char *pinstance;            /* Principal's instance */
     char *prealm;               /* Principal's authentication domain */
-    unsigned long *paddress; /* Net address of entity
+    unsigned KRB4_32 *paddress; /* Net address of entity
                                  * requesting ticket */
     C_Block session;            /* Session key inserted in ticket */
     int *life;                  /* Lifetime of the ticket */
-    unsigned long *time_sec; /* Issue time and date */
+    unsigned KRB4_32 *time_sec; /* Issue time and date */
     char *sname;                /* Service name */
     char *sinstance;            /* Service instance */
     C_Block key;                /* Service's secret key