]> asedeno.scripts.mit.edu Git - 1ts-debian.git/commitdiff
greg's bug fix
authorkcr <kcr@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Sun, 21 Oct 2001 19:29:47 +0000 (19:29 +0000)
committerkcr <kcr@cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f>
Sun, 21 Oct 2001 19:29:47 +0000 (19:29 +0000)
git-svn-id: svn://svn.1ts.org/debian/trunk/zephyr@109 cbed1d16-5ef5-0310-b6a1-d4a37b08ba1f

debian/changelog
zwgc/tty_filter.c

index bd94693f1139b6f9de3abd8a2c9b7a4e45ee6212..dec488e8f4b664b35e5be4509d7013a77f67295b 100644 (file)
@@ -5,9 +5,11 @@ zephyr (2.1.20010518.SNAPSHOT-3) unstable; urgency=low
   * Spanish translation for zephyr-server debconf, closes #106573, #106572
   * Spanish translation for zephyr-clients debconf, closes #106571
   * include hints for people trying to use zephyr-server-krb, closes: #106852
-  * attempt to get some small bits of documentation into /usr/share/doc/...
+  * attempt to get some small bits of documentation into
+    /usr/share/doc/...
+  * fix formatting bug.  closes: #116389
 
- -- Karl Ramm <kcr@debian.org>  Sat, 20 Oct 2001 12:25:07 -0400
+ -- Karl Ramm <kcr@debian.org>  Sun, 21 Oct 2001 15:27:08 -0400
 
 zephyr (2.1.20010518.SNAPSHOT-2) unstable; urgency=low
 
index ed81b701d28a6b38f589e01a1fa7834ad1e66708..27dc57bb082bea9b566fb2aa760fbc2a68ae69e2 100644 (file)
@@ -327,6 +327,7 @@ static tty_str_info *convert_desc_to_tty_str_info(desc)
 
        /* Add new block (call it temp) to result: */
        temp = (tty_str_info *)malloc(sizeof(struct _tty_str_info));
+       *temp = current_mode;
        if (last_result_block) {
            last_result_block->next = temp;
            last_result_block = temp;
@@ -350,13 +351,13 @@ static tty_str_info *convert_desc_to_tty_str_info(desc)
        }
        if (desc->code == DT_STR) {
            /* just combine string info with current mode: */
-           *temp = current_mode;
            temp->str = desc->str;
            temp->len = desc->len;
        } else if (desc->code == DT_NL) {
            /* make the new block a ' ' alignment block with an empty string */
            temp->alignment = ' ';
            temp->len = 0;
+           temp->ignore = 0;
        }
     }